WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

PHP Version Finder

— Add- On til WorldWideScripts.net

Abonner på vårt feed for å holde deg oppdatert!

Nyhet! Følg oss som du vil ha det!


PHP Version Finder - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Følg meg på Twitter Følg meg på G + Følg meg på CodeCanyon Live Demo

Demo - Ikke Database (lammet)
Demo - Database (lammet)
Demoene er ødelagt! Vi har krabbet den sanne versjonen av hver funksjon og utvidelse.

PHP versjon Finder - Oppdatert til v 1.0.3c 12/9/2010

Finn hvilken versjon av PHP skriptet krever. På spørsmål om hva versjon av PHP kreves for å kjøre våre skript vi ikke har et endelig svar. Vi har laget dette skriptet til å bestemme PHP versjon, og da vi tok det til et annet nivå ved å oppsøke utdaterte funksjoner. Men vi stoppet ikke bare på det. Vi inkluderte PHP Extensions og språkkonstruksjoner. Vi nesten kalte det bra på det, men da vi lurte på... hvor mange ganger vi har brukt disse funksjonene. Overdreven bruk av den samme funksjon kan degradere ytelse. Overvåking hvor mange ganger funksjonen brukes kan finne ut om en "User Created Function" kan bli opprettet for å redusere kode og øke ytelsen.

Gjenkjenning

PHP versjon Finder spor: 3044 PHP funksjoner, 2260 PHP extensions, 23 språkkonstruksjoner, 19 alternative forslag, 7 Tips / triks / Notater. (Pluss 69 Experimental, 20 avviklet, 47 "svn" funksjoner)
Koden er ikke nødt til å være komplett eller fungerer. Det trenger ikke engang å være fornuftig. Så lenge det er mellom <? Php og?> Det vil bli evaluert. Invalidiserte Demo - Demoen er lammet å hindre folk fra å bruke den i stedet for å kjøpe den.

Stopp gjette!

Når sant skal sies - de fleste utviklere "ball-park" hvilken versjon av PHP er nødvendig ved å hente noen "viktige" funksjoner de brukte. Med PHP versjon Finder kan du vite sikkert hva PHP versjon er faktisk nødvendig!
Ikke Gjett! - Kjør PHP versjon Finder på skriptet å vite sikkert hva verions av PHP er nødvendig for å betjene script!

frarådet Detection

PHP versjon Finder lar deg vite om noen funksjoner du brukte er foreldet.
Avviklet Detection - Sjekk dine skript for utgående funksjoner

to versjoner

PHP versjon Finder krever ikke en database. Men for de av dere som heller vil bruke en database, gjør skriptet inkluderer en database versjon.
Optionhal Database - PHP versjon finder ikke krever en database, derimot, er en alternativ versjon leveres for de som ønsker å bruke en database.
Hvorfor to versjoner?
Det hele kommer ned til tall. Hvis det er mange PHP-funksjoner, er den IKKE databaseversjonen raskere. Hvis det er bare noen få funksjoner, er databasen versjon raskere. Hvor mye raskere? Vel, det er målt i mikro sekunder. Så egentlig ikke merkbar. Etter at vi har gjort i databasen versjonen vi besluttet at det ikke var verdt innsatsen som ytelsen var ikke merkbar annerledes. Vi bestemte oss for å ta det fordi det allerede var bygget - en freebie om du vil.

Installasjon

Installasjonen er enkel. Last opp katalogen, redigere to innstillinger, og du er ferdig.
Installion - Last opp en katalog til serveren, redigere en config fil og klar til å gå!

innganger

Du kan laste opp en fil fra datamaskinen, skanne en fil eller hele katalogen på serveren, eller lime inn koden i en boks for behandling.
Flere innganger - Du kan laste opp en fil, skann en katalog eller sjekke en blokk med kode.

alternative forslag

Hvis PHP versjon Finder finner funksjoner som er utdaterte, vil det gi deg alternative forslag som kan erstatte det nedgraderte funksjon.
Alternative forslag - Du kan lage din script For eksempel:
hvis du bruker file_put_contents (som krever PHP 5), vil PHP versjon Finder fortelle deg at du kan bruke fwrite i stedet som kunne senke den nødvendige versjonen ned til PHP 4. Ikke bare det, men det er en lapp klistret på file_put_contents som viser deg koden for å bruke til å lage file_put_contents bakoverkompatibel.

Kjøp PHP versjon Finder NÅ!

Gjør livet enkelt! Finn utdaterte funksjoner, få bakoverkompatibel forslag og vet hvilken versjon av PHP er nødvendig for å kjøre skript
Kjøp nå - gjøre livet enkelt, finne nedgraderte funksjoner, få bakoverkompatibel forslag og vet hvilken versjon av PHP er nødvendig for å kjøre skript.

Nåværende funksjoner (v 1.0.0) - 12/1/2010

  • valgfritt Database
  • frarådet Detection
  • Filopplasting Processing
  • Directory Processing
  • Limt Processing Kode
  • Autofullfør
  • syntax Highlighter
  • 3044 PHP funksjoner
  • 2260 PHP Extensions
  • 23 språkkonstruksjoner
  • 19 alternative forslag
  • 7 tips / triks / Notes
  • Plus 69 Eksperimentelle funksjoner
  • Pluss 20 utgående funksjoner
  • Plus 47 "svn" / ukjente funksjoner

Oppdater v 1.0.1 12/3/2010

  • Faste Kjøps advarsler
  • Fixed "udefinerte variabler" Feil
  • Faste stavefeil
  • Oppdatert hjelpefilen for å reflektere endringer
  • Lagt Licensing Forklaring
  • Ryddet opp "Report File"

Oppdater v 1.0.2 12/4/2010

  • Faste Kjøps advarsler
  • Fixed "udefinerte variabler" Feil
  • Oppdatert hjelpefilen for å reflektere endringer

Oppdater v 1.0.3c 12/9/2010

  • Ryddet opp kode
  • Omskrev hvordan statistikken er telt.
  • Omskrev "Report File"

Laste ned
Andre komponenter i denne kategorienAlle komponenter av denne forfatteren
KommentarerOfte stilte spørsmål og svar

Egenskaper

laget:
03.12.10

Siste oppdatering:
10.12.10

Høy oppløsning:
Nei

kompatible nettlesere:
IE7, IE8, Safari, Opera

filer Inkludert:
Javascript JS, HTML, CSS, PHP, SQL

Programvareversjon:
PHP 4.x, PHP 5.x, PHP 5,0 til 5,2, PHP 5.3, MySQL 5.x

Søkeord

eCommerce, eCommerce, Alle ting, frarå, det advarsel, php versjon, syntax highlighting